scrambler
Posts: 144
Joined: Sat Jan 14, 2017 4:11 pm

Sport mode not working

Sun Feb 12, 2017 6:12 pm

I just noticed the Sport mode button on my New "used" Spark EV does not do anything (no Sport showing up on the screen).
I dont really use Sport mode, but I dont like things that dont work :)

All I can think of is that the switch would have gone bad.

I was wondering if anyone had the issue, and if anyone knows how to disassemble the switch to test it.

Thanks

nikwax
Posts: 567
Joined: Sun Apr 26, 2015 3:27 pm
Location: Portland, Oregon

Re: Sport mode not working

Sun Feb 12, 2017 6:52 pm

Sport mode is fun, I use it much of the time. Sport mode and L make for a very fun driving experience.
2015 Spark EV 1LT DCFC
BF Goodrich g-Force Super Sport A/S
ClipperCreek EVSE

evboy
Posts: 191
Joined: Mon Jan 12, 2015 2:05 am

Re: Sport mode not working

Sun Feb 12, 2017 7:04 pm

nikwax wrote:Sport mode is fun, I use it much of the time. Sport mode and L make for a very fun driving experience.
i dont feel a difference between sport and non sport. i just leave it off and drive in l

emv
Posts: 193
Joined: Sun Mar 02, 2014 10:47 pm
Location: PDX

Re: Sport mode not working

Sun Feb 12, 2017 9:41 pm

I'm sure somebody will correct me if I'm wrong but I believe all sport mode does is remap the accelerator pedal so that you get more oomph with less press of the pedal. Floorboard it and there is no difference. It's akin to changing the taper on a potentiometer.
2014 Spark, 2005 Prius. When we take the Prius we say we're taking the gas hog.

nikwax
Posts: 567
Joined: Sun Apr 26, 2015 3:27 pm
Location: Portland, Oregon

Re: Sport mode not working

Mon Feb 13, 2017 12:33 pm

emv wrote:I'm sure somebody will correct me if I'm wrong but I believe all sport mode does is remap the accelerator pedal so that you get more oomph with less press of the pedal. Floorboard it and there is no difference. It's akin to changing the taper on a potentiometer.

That's what it does. More fun (for me) and probably less energy efficient.
2015 Spark EV 1LT DCFC
BF Goodrich g-Force Super Sport A/S
ClipperCreek EVSE

TheLondonBroiler
Posts: 200
Joined: Tue Oct 31, 2017 6:25 am

Re: Sport mode not working

Tue Jan 30, 2018 7:42 am

Ever get this figured out?

I test drove a Spark EV with this very same issue, and they said they would get it in to service that night so that I could purchase it. They called me the next day and asked if I was ready to come by and sign paperwork. I asked then if they'd figured out the issue. Salesman told me they weren't able to look at it. I said, funny coincidence, I wasn't able to take a look at the sales paperwork either :)
2015 Spark EV w/ DCFC 46,XXX miles
Purchased 1/20/18 w/ 16,5XX miles
0-40k mile efficiency avg - 5.3 mi/kwh

2019 Bolt EV w/ DCFC 57,XXX miles
Purchased 3/16/19 w/ 87 miles
Lifetime efficiency avg - 4.6 mi/kwh

NORTON
Posts: 1288
Joined: Fri May 01, 2015 5:52 am
Location: KC,MO

Re: Sport mode not working

Tue Jan 30, 2018 12:35 pm

It really is a subjective thing.

How do you really know it's not working?

Full Go Pedal = Full Power. No matter what.

How can you quantify it,what do you do? Measure Go Pedal movement in tenths of an inch vs kW on the power display?
I never use it. When I lend it out I ask if they can tell the difference. Not much.
Used '14 2LT w/ DCFC. +80 K miles.
Mostly free charging! Only one LONG visit to the shop....
GM needs Modern Troubleshooting tools for Modern EV's.
3 step Trouble Tree, 1st try car died again, 2nd try not covered / cost $800. 3rd try fixed the problem.

TheLondonBroiler
Posts: 200
Joined: Tue Oct 31, 2017 6:25 am

Re: Sport mode not working

Wed Jan 31, 2018 7:56 am

NORTON wrote:
How do you really know it's not working?

Full Go Pedal = Full Power. No matter what.
Right on both points I believe. Only an owner that uses both modes A LOT, could distinguish with no indicator.

I had my new to me Spark EV at the Chevy dealer yesterday to squeak in some final bumper to bumper warranty work, the rear passenger door wouldn't show as open on the DIC and wouldn't operate the dome light. I determined the pin switch was good, and the wire was connected, I wasn't willing to put forth any more effort with warranty remaining. Dealership technician diagnosis, broken wire. I asked, what do you believe cause this to occur, to which they responded, it broke near the door jam, we don't know. Years ago, when I worked on cars professionally, the only time I saw broken wires was on a couple jeeps and fords in between the door and body.

I was curious if the Sport mode was disabled by a broken wire, leading me to wonder, do we have very weak wires? The Money Pit joke reference aside, I'm curious if there are forces on some harness(es) that are legitimately capable of causing either wire breaks or disconnects at molex connectors. I might go digging one day if I get bored, cause I ain't scured to start disassembling interior panels.
2015 Spark EV w/ DCFC 46,XXX miles
Purchased 1/20/18 w/ 16,5XX miles
0-40k mile efficiency avg - 5.3 mi/kwh

2019 Bolt EV w/ DCFC 57,XXX miles
Purchased 3/16/19 w/ 87 miles
Lifetime efficiency avg - 4.6 mi/kwh

JeffTAC4
Posts: 17
Joined: Mon Feb 13, 2017 12:05 am

Re: Sport mode not working

Sat Nov 16, 2019 7:11 pm

Dead thread, I know, but did anyone ever figure this out, by chance?

I've had my Spark EV for nearly 3 years now, and the Sport button just stopped working this week out of the blue. No software or hardware changes, nothing else out of the ordinary. No CEL or trouble codes. The sport button still lights up like usual.

Press the button, Sport does not come up on the DIC and the performance "map" is still set to normal (trust me, my butt dyno can tell).

I haven't tried anything to fix it yet, just checking to see if anyone else has.

Thanks,
Jeff

scrambler
Posts: 144
Joined: Sat Jan 14, 2017 4:11 pm

Re: Sport mode not working

Sat Nov 16, 2019 7:25 pm

I bough a used spark and the sport mode button never worked.
Not that I need it really, you can floor it when you need it :)

Return to “General / Main Owners Forum”