SparkE
Posts: 411
Joined: Tue Sep 06, 2016 1:18 am
Location: SF Bay Area (San Jose, CA)

Re: Electrify America Charging Station Problems

Fri Sep 11, 2020 10:34 am

OK, I just read this elsewhere (another site) :


All the charges were pretty much uneventful, once I learned how to properly work EA chargers: plug in first, wait for CC screen to show on charger (about 20 seconds, after "initializing" box shows), THEN swipe in the app (I got the $4 membership). Any swiping too early caused a fail and I'd have to move or wait and try again. EA support was NOT helpful in this regard: every one of their reps told me to swipe in the app "within a few seconds" after plugging in. That doesn't work. You have to wait. But you all know this by now :D


Sorry i didn't post this before your trip, but the original was posted about an hour ago!

SparkE
Posts: 411
Joined: Tue Sep 06, 2016 1:18 am
Location: SF Bay Area (San Jose, CA)

Re: Electrify America Charging Station Problems

Fri Sep 11, 2020 10:37 am

Same user, different post ... :

The rest of my EA experiences on my 2400 mile road trip (10 EA total) were ok, once I realized how you MUST start the chargers (any deviation from this exactly would fail for me until I learned the process)

SIGN UP for a membership. Pay the $4/mo. In my case it was way worth it to save money and hassle.

Make sure the port is shown as working on the display

Plug in first, hold the plug by pulling up firmly so you maintain full contact with your vehicle port

Have your app ready to swipe with your other hand

WAIT TO SWIPE on the app until the credit card screen comes up on the pedestal screen

THEN swipe. If you swipe too early, it will fail.

Each time I would call, EA reps would tell me to "swipe within a couple seconds of plugging in", while the "initiating" box was showing on the pedestal and app. That guarantees a fail, temporarily rendering that port/cable unusable until it times out.

Now that I have the EA dance down, I'm good.

NORTON
Posts: 1337
Joined: Fri May 01, 2015 5:52 am
Location: KC,MO

Re: Electrify America Charging Station Problems

Fri Sep 11, 2020 2:09 pm

Thanks, SparkE !

Now you tell me..... :roll: 8-)

I'm really burned after this EV Road Trip.
It will be a while before I'm ready again.
I looked and I can go to northern Mi !
Traverse City, Mi.

The EV Highway is much more complete than I ever imagined!
Used '14 2LT w/ DCFC. +85k miles.
Mostly free charging! Only one LONG visit to the shop....
GM needs Modern Troubleshooting tools for Modern EV's.
3 step Trouble Tree, 1st try car died again, 2nd try / cost $800. 3rd try fixed the problem.

SparkE
Posts: 411
Joined: Tue Sep 06, 2016 1:18 am
Location: SF Bay Area (San Jose, CA)

Re: Electrify America Charging Station Problems

Mon Sep 14, 2020 12:00 pm

NORTON wrote:
Fri Sep 11, 2020 2:09 pm
I looked and I can go to northern Mi !
Traverse City, Mi.

The EV Highway is much more complete than I ever imagined!
I can highly recommend Traverse City, Mi ! :D Even better is a tiny bit further north, up route 22 to Suttons Bay or Omena. Beautiful country, lots of orchards, vineyards, dairies , etc so you can make it a gastro-trip ! I'd go in summer-fall.

Return to “Batteries and Charging”